1. Welcome Guest! In order to create a new topic or reply to an existing one, you must register first. It is easy and free. Click here to sign up now!.

[Solved] Very Slow Upload Speeds

Discussion in 'Windows 7' started by John Stenger, Dec 2, 2018.

  1. John Stenger

    John Stenger Registered Members

    Joined:
    Apr 2, 2013
    Messages:
    196
    Operating System:
    Windows XP Home
    I have a Dell Optiplex 780 running windows 7 and I have been having very slow upload speeds lately, and because I believed it to be my Modem/Router I purchased a new one but, I am having the same upload issue as with the old modem! I'm not sure what info to post here! I have Comcast Xfinity which they checked and confirmed as working normally. Download speed is better then excellent, I have replaced Ethernet cable, reset modem 3 times! I have tried everything I can think of that might effect uploading this but so far, no luck. Any help would be appreciated.
     
  2. Tony D

    Tony D Super-Moderator Super Moderators

    Joined:
    Sep 25, 2009
    Messages:
    2,758
    Location:
    SE Pennsylvania, USA
    Operating System:
    Windows XP Professional
    Hi John, what is your upload speed and where did you check it?

    Have you tried using Chrome?

    Have you tried switching your DNS settings to OpenDNS?

    Open a command prompt and enter these commands, one-by-one

    ipconfig /release
    ipconfig /renew
    ipconfig /flushdns
    netsh winsock reset all
    netsh int ip reset all
    Exit
     
  3. plodr

    plodr CHF Advisor CHF Advisers

    Joined:
    May 31, 2017
    Messages:
    304
    Operating System:
    Windows 7
    Is your modem and router one unit or two?
    If two units, power down the modem, attach the computer directly to the modem then power it up again and post if the upload speeds have improved.
     
  4. John Stenger

    John Stenger Registered Members

    Joined:
    Apr 2, 2013
    Messages:
    196
    Operating System:
    Windows XP Home
    Hello, Tony D & Plodr ...My upload speeds vary from 0.3 to maybe 4.2 sometimes the upload test stops and shows Error it's so slow, I use several speed tests including Xfinitys. My modem is a combo modem/Router. I have tried it in Chrome but no change! I will now try the DNS you have suggested and post results. Thanks
     
  5. John Stenger

    John Stenger Registered Members

    Joined:
    Apr 2, 2013
    Messages:
    196
    Operating System:
    Windows XP Home
    The DNS must have been the issue TonyD, after entering the commands I ran a speed test and upload speed went to 7.9! and with another test almost 9 ...are these DNS settings something to reset whenever things are slowing down, or are these permanent settings?
     
    Last edited: Dec 3, 2018
    allheart55 (Cindy E) likes this.
  6. Tony D

    Tony D Super-Moderator Super Moderators

    Joined:
    Sep 25, 2009
    Messages:
    2,758
    Location:
    SE Pennsylvania, USA
    Operating System:
    Windows XP Professional
    Keep them permanent. You'll be fine.
     
  7. John Stenger

    John Stenger Registered Members

    Joined:
    Apr 2, 2013
    Messages:
    196
    Operating System:
    Windows XP Home
    Thanks Tony & plodr, ...I appreciate your Help!
     

Share This Page