1. Welcome Guest! In order to create a new topic or reply to an existing one, you must register first. It is easy and free. Click here to sign up now!.
    Dismiss Notice

Strange Settings

Discussion in 'Windows 7' started by BGBG, May 27, 2022.

  1. BGBG

    BGBG Registered Members

    Joined:
    Dec 11, 2014
    Messages:
    1,831
    Operating System:
    Windows 7
    In my Google Settings/Autofill/Passwords I found something named _cw.14eclinicalweb.com with my email address and password. What IS this...I never heard of it before and never that I know of signed up for it. It is totally unknown to me and if used takes me to an unfamiliar website and may be causing trouble with my logins I recall creating. Does anyone know what these are? I am afraid to click Remove after clicking the 3 vertical dots at top right corner of webpageand Autofill because I do not know it that is correct thing to do. Can anyone help me?
     
    Last edited: May 27, 2022
  2. allheart55 (Cindy E)

    allheart55 (Cindy E) Administrator Administrator

    Joined:
    Jun 11, 2009
    Messages:
    10,260
    Location:
    Pennsylvania
    Operating System:
    Windows 10
    Computer Brand or Motherboard:
    ASUS M4A77TD AM3 AMD 770 ATX AMD
    CPU:
    AMD Phenom II X6 1090T-Thuban 3.2GHz
    Memory:
    Crucial-DDR3 SDRAM 1333-8GB
    Hard Drive:
    WD Caviar Black SE HDD 640 GB - WD Caviar Black SE HDD 500 GB
    Graphics Card:
    Sapphire Radeon HD-7870 2GB
    Power Supply:
    CORSAIR CMPSU-750W
    Go ahead and remove it, Bill.
    You don't need it.
     
    IJAC likes this.
  3. BGBG

    BGBG Registered Members

    Joined:
    Dec 11, 2014
    Messages:
    1,831
    Operating System:
    Windows 7
    Thanks Cindy. I shall do that. Just needed some input. Think it is a medical records site but I do not remember signing up or making a login & password
     
  4. allheart55 (Cindy E)

    allheart55 (Cindy E) Administrator Administrator

    Joined:
    Jun 11, 2009
    Messages:
    10,260
    Location:
    Pennsylvania
    Operating System:
    Windows 10
    Computer Brand or Motherboard:
    ASUS M4A77TD AM3 AMD 770 ATX AMD
    CPU:
    AMD Phenom II X6 1090T-Thuban 3.2GHz
    Memory:
    Crucial-DDR3 SDRAM 1333-8GB
    Hard Drive:
    WD Caviar Black SE HDD 640 GB - WD Caviar Black SE HDD 500 GB
    Graphics Card:
    Sapphire Radeon HD-7870 2GB
    Power Supply:
    CORSAIR CMPSU-750W
    That happens to me all of the time.
     

Share This Page