1. Welcome Guest! In order to create a new topic or reply to an existing one, you must register first. It is easy and free. Click here to sign up now!.
    Dismiss Notice

Keyboard Help

Discussion in 'Miscellaneous Hardware' started by Winterfox720, Oct 10, 2021.

  1. Winterfox720

    Winterfox720

    Joined:
    Oct 10, 2021
    Messages:
    3
    Operating System:
    Windows 10
    So every time I press certain keys it presses others such as pressing alt it presses the calculator key and the 6 key under numlock only. I have checked if its the software(I run win 1o) and its not that and ive taken the keyboard out and that doesnt help as external keyboards do the same. Does anyone have a solution/idea on what it is? Any help would be appreciated
     
  2. plodr

    plodr CHF Advisor CHF Advisers

    Joined:
    May 31, 2017
    Messages:
    744
    Operating System:
    Windows 7
    Is this a laptop? If so and an external keyboard works as poorly as the laptop keyboard then it is not a hardware problem. If not hardware, then that means it is software.

    It helps if you post the brand and model of the laptop.
     
  3. Tony D

    Tony D Administrator Administrator

    Joined:
    Sep 25, 2009
    Messages:
    4,329
    Location:
    SE Pennsylvania, USA
    Operating System:
    Windows XP Professional
    You removed it from the laptop?
     
  4. Seth Anthony

    Seth Anthony Registered Members

    Joined:
    Mar 31, 2017
    Messages:
    1,394
    Operating System:
    Linux Based
    Computer Brand or Motherboard:
    Altaire 8800
    CPU:
    Modified Texas Instruments calculator
    Memory:
    2 transistor tubes
    Hard Drive:
    pen and paper
    Graphics Card:
    TV ready
    Power Supply:
    Mouse on a wheel
    I've gone through this with numerous customers. It's probably your language/region/keyboard settings, especially given that you tried another keyboard. Make sure all of those settings are set to U.S. English, and remove any others you might see. It could also be a keyboard layout setting.
     
    IJAC and Tony D like this.
  5. Winterfox720

    Winterfox720

    Joined:
    Oct 10, 2021
    Messages:
    3
    Operating System:
    Windows 10
    Thats what I thought aswell but it's not only in windows. I loaded Linux from my boot stick but the same issue happened there aswell.


    Yea I figured that maybe the ribbon was dirty or something and maybe that was causing the issue- it was dirty but that wasn't the issue.
     
  6. Seth Anthony

    Seth Anthony Registered Members

    Joined:
    Mar 31, 2017
    Messages:
    1,394
    Operating System:
    Linux Based
    Computer Brand or Motherboard:
    Altaire 8800
    CPU:
    Modified Texas Instruments calculator
    Memory:
    2 transistor tubes
    Hard Drive:
    pen and paper
    Graphics Card:
    TV ready
    Power Supply:
    Mouse on a wheel
    Well that completely changes things :). Since the issue occurs in Windows, Linux, and you tried an external keyboard, then it means you have a motherboard problem, or something is awry in the bios. Check the bios for keyboard settings.
     
    Last edited: Oct 10, 2021
    plodr, IJAC and Tony D like this.
  7. Seth Anthony

    Seth Anthony Registered Members

    Joined:
    Mar 31, 2017
    Messages:
    1,394
    Operating System:
    Linux Based
    Computer Brand or Motherboard:
    Altaire 8800
    CPU:
    Modified Texas Instruments calculator
    Memory:
    2 transistor tubes
    Hard Drive:
    pen and paper
    Graphics Card:
    TV ready
    Power Supply:
    Mouse on a wheel
    IJAC likes this.
  8. Winterfox720

    Winterfox720

    Joined:
    Oct 10, 2021
    Messages:
    3
    Operating System:
    Windows 10
    That does seem to be the issue but I dont have the option to disable it. I just ran a keyboard test and it seems certain keys are pressing things on the numpad somehow. I have a precision m4600 (Just found out the type it is finally) I checked the bios setup and there wasn't an option to disable that area do you have an idea to do that?
     
  9. Seth Anthony

    Seth Anthony Registered Members

    Joined:
    Mar 31, 2017
    Messages:
    1,394
    Operating System:
    Linux Based
    Computer Brand or Motherboard:
    Altaire 8800
    CPU:
    Modified Texas Instruments calculator
    Memory:
    2 transistor tubes
    Hard Drive:
    pen and paper
    Graphics Card:
    TV ready
    Power Supply:
    Mouse on a wheel
    There pretty much has to be a way to disable it in the BIOS. Perhaps take a pictures of that BIOS setting and include it in your next reply.

    To confirm, you disconnected the internal keyboard, connected an external keyboard (keeping the internal keyboard disconnected), and tried it with both Linux and Windows, but the problem remained. Correct? Again, if that is all correct, then you have a motherboard problem, or it's a bios setting.

    Another thing to try, is go into the bios and restore it to factory default, then make sure you apply or save the changes.
     
    Tony D and IJAC like this.
  10. 8_Ball

    8_Ball Registered Members

    Joined:
    Jul 24, 2019
    Messages:
    56
    Operating System:
    Windows 10
    It's highly unlikley to be a BIOS setting on a latop where you probably never even messed with the BIOS to begin with right and it happens on your laptop keyboard and a USB connected keyboard too right? Assuming that this laptop once ran correctly for you. So even though you said you checked the software, something isn't right. Think about when this started happening and go from there. If you did an operating system re-install (to Dell Factory defaults) or a System Restore possibly, that is going to actually tell you if this was software or not.
     
  11. Seth Anthony

    Seth Anthony Registered Members

    Joined:
    Mar 31, 2017
    Messages:
    1,394
    Operating System:
    Linux Based
    Computer Brand or Motherboard:
    Altaire 8800
    CPU:
    Modified Texas Instruments calculator
    Memory:
    2 transistor tubes
    Hard Drive:
    pen and paper
    Graphics Card:
    TV ready
    Power Supply:
    Mouse on a wheel
    8ball,

    Winterfox has already has ruled out a Windows language, region, and keyboard setting, and also booted to Linux in which the problem remained. Given all that, how do you figure it's a software issue?
     
    plodr and IJAC like this.
  12. 8_Ball

    8_Ball Registered Members

    Joined:
    Jul 24, 2019
    Messages:
    56
    Operating System:
    Windows 10
    Sent Anthony,

    I saw that. and I have had a few units with that double keyboard issue but it's rare, and yes it's easy to test with a Linux Live boot. I would tend to think it's actually a mainboard issue as you had mentioned. So I don't think it's software at all. The point was it's something I would have tried anyway. I would have set a restore point (to go back too) and tried an earlier restore point.
     

Share This Page