1. Welcome Guest! In order to create a new topic or reply to an existing one, you must register first. It is easy and free. Click here to sign up now!.
    Dismiss Notice

I got PSU problem, which I need to solve quickly

Discussion in 'Power Supply - PSU' started by LanmiS, Dec 9, 2013.

  1. LanmiS

    LanmiS

    Joined:
    Dec 9, 2013
    Messages:
    1
    Operating System:
    Windows XP Professional
    I'm not computer genius, so please keep it simple :)

    My old power supply is dead...I bought new one, connected everything...and when I started my computer, it all looked fine.
    Windows started working, no problem and then, computer just turn off after about 30 sec. When I started it again, it worked for about 30 sec. and again it turned off.

    When I took another power supply, connected it, turned computer on, and my pc monitor was totaly blank, nothing to see and pc case was running nowmally.

    Can you please help me solve this, I know that I probably haven't explained it well, so if you need any more questions feel free to ask, I will try to answer if I can.

    Thanks in advance for your help and your time.
    Best regards
    LanmiS
     
  2. DSTM (Dougie)

    DSTM (Dougie) Registered Members

    Joined:
    May 3, 2009
    Messages:
    8,270
    Location:
    SYDNEY AUSTRALIA
    Operating System:
    Windows 7
    Hi and welcome to Computer Help Forums.

    Excess heat at the heatsink can cause a computer to shut down in as little as 30 secs.

    First thing I would do is put fresh thermal paste on the heatsink.

    Nail polish remover cleans the old paste off pretty well.

     
  3. Tony D

    Tony D Super-Moderator Super Moderators

    Joined:
    Sep 25, 2009
    Messages:
    3,326
    Location:
    SE Pennsylvania, USA
    Operating System:
    Windows XP Professional
    Adding to DSTM's advice, how do you know it was the PSU that failed? What tests did you run?

    Were you having any other issues before this?
     
    Last edited: Dec 10, 2013
  4. PseFrank

    PseFrank Registered Members

    Joined:
    Nov 10, 2010
    Messages:
    962
    Location:
    Cambridge UK
    Operating System:
    Windows 7
    Good points have already been made above. Can you tell us LanmiS what were your exact symptoms before changing the power supply unit?
     
  5. Rich M

    Rich M Guest

    Joined:
    Dec 24, 2013
    Messages:
    4,580
    Location:
    NE Pa USA
    Operating System:
    Windows 7
    Computer Brand or Motherboard:
    MSI Z97 PC Mate LGA 1150 Intel Z97
    CPU:
    Intel i7 4790K 4.0Ghz
    Memory:
    Corsair Vengeance 16GB (2x8GB) DDR3 2133
    Hard Drive:
    Crucial 256 Gb SSD+ WD Raptor 300 Gb Sata III
    Graphics Card:
    Radeon R9 280 2GB HDMI
    Power Supply:
    Seasonic 750 watt
    Can you also tell us about your computer including make and model or hardware if custom build and especially make and wattage of new psu as well?
     

Share This Page