1. Welcome Guest! In order to create a new topic or reply to an existing one, you must register first. It is easy and free. Click here to sign up now!.
    Dismiss Notice

Google 'Safe Search' - can't turn 'off'

Discussion in 'Windows 7' started by kwil, Sep 8, 2021.

  1. kwil

    kwil

    Joined:
    Sep 8, 2021
    Messages:
    3
    Operating System:
    Windows 7
    Hi all



    I'm still running Windows 7 (64-bit) Home Premium on my desktop computer and would like to keep it that way.


    I've never had any problem using Google Chrome browser until a couple of days ago.

    However, despite working perfectly before all this, it's now showing 'Safe Search On' and I can't find a way to turn it 'off'.


    I've not introduced any new software whatsoever and everything else on the computer works perfectly.



    Changing Safe Search to 'off' used to be possible via Settings but that option to turn off content filtering no longer seems to exist.


    All information online indicates this problem with Safe Search staying 'on' has existed for a long time.


    I've followed all the 'advice' online but find you're looped back to the same 'locked' situation no matter what you do.



    What I've done so far:


    1. Followed online 'advice' from Google


    2.Tried uninstalling then reinstalling Google fresh


    3. Tried 'System Restore' to earlier date


    No luck with any of these moves.



    Now, I know Google has said it was stopping support for Windows 7 in July 2021, but, because of the pandemic, this has been extended to January 2022.


    I'm just wondering if in fact Google has jumped the gun on its support for Win7.


    Has anyone else had this problem or started to experience it and if so, is there a solution?

    I'd appreciate any thoughts or suggestions on the matter.

    Many thanks

     
  2. Tony D

    Tony D Administrator Administrator

    Joined:
    Sep 25, 2009
    Messages:
    4,280
    Location:
    SE Pennsylvania, USA
    Operating System:
    Windows XP Professional
    Hello and welcome Kwill,

    Go to Chrome's Settings.
    Under Privacy and security, click on Security.
    The options are there.
     
    plodr, allheart55 (Cindy E) and IJAC like this.
  3. kwil

    kwil

    Joined:
    Sep 8, 2021
    Messages:
    3
    Operating System:
    Windows 7
    Hello Tony,

    Thanks for taking time to reply.
    I've already tried that umpteen tmes. There are NO options there to 'turn off'.
    In the past, it was a simple check box on/off.

    This was so even after I reinstalled Google Chrome like I mentioned.

    Clicking 'Privacy/Security' then 'Security' brings up: 'Enhanced/Standard/No Protection' window

    I chose 'No Protection' - of course it said 'not recommended' - but the Save Search was STILL locked 'on'!!

    At top right: 'Save Search On'

    As I've said, any move you make is looped back to above. Really irritating.

    Any other ideas?


    Many thanks
     
  4. kwil

    kwil

    Joined:
    Sep 8, 2021
    Messages:
    3
    Operating System:
    Windows 7
    Meant to add: I've run full anti-virus scans/malware checks including Malwarebytes.
    All clear...
     
  5. Seth Anthony

    Seth Anthony Registered Members

    Joined:
    Mar 31, 2017
    Messages:
    1,377
    Operating System:
    Linux Based
    Computer Brand or Motherboard:
    Altaire 8800
    CPU:
    Modified Texas Instruments calculator
    Memory:
    2 transistor tubes
    Hard Drive:
    pen and paper
    Graphics Card:
    TV ready
    Power Supply:
    Mouse on a wheel
  6. Seth Anthony

    Seth Anthony Registered Members

    Joined:
    Mar 31, 2017
    Messages:
    1,377
    Operating System:
    Linux Based
    Computer Brand or Motherboard:
    Altaire 8800
    CPU:
    Modified Texas Instruments calculator
    Memory:
    2 transistor tubes
    Hard Drive:
    pen and paper
    Graphics Card:
    TV ready
    Power Supply:
    Mouse on a wheel
    Continued from my previous post:

    If the reset doesn't help, then does the issue occur in other internet browsers? If it occurs in other browsers, you may have some safe search/ content filtering enabled on your ISP account.
     
    Tony D likes this.
  7. plodr

    plodr CHF Advisor CHF Advisers

    Joined:
    May 31, 2017
    Messages:
    726
    Operating System:
    Windows 7

Share This Page