1. Welcome Guest! In order to create a new topic or reply to an existing one, you must register first. It is easy and free. Click here to sign up now!.
    Dismiss Notice

Device Manager not recognizing USB Plug & Play Sound Card

Discussion in 'Windows Vista' started by bdnh85, Jun 23, 2016.

  1. bdnh85

    bdnh85

    Joined:
    Jun 23, 2016
    Messages:
    4
    Operating System:
    Windows Vista Home Premium
    I have a Windows Vista. What I'm doing with it

    2 police scanners.

    1. Is hooked up to the PC sound card and Using Pro Scan to record.

    2. Scanner # 2 is hooked up via USB Sound Card but when I plug it in, I check the device manager and notice that device manager does not show up. When I go to volume mixer it's listed there. I need to be able to hook scanner #2 up to record on Proscan which you can, But in the program to change audio it says "Unknown" before there Microphone & Delkin forget the last name and both have been replaced with "Unknown"
     
  2. Tony D

    Tony D Administrator Administrator

    Joined:
    Sep 25, 2009
    Messages:
    4,562
    Location:
    SE Pennsylvania, USA
    Operating System:
    Windows XP Professional
    Hello and welcome bdnh85. Can you tell us what model that USB Sound Card is? I'm wondering if it needs a driver installed.
    Thanks,
     
  3. bdnh85

    bdnh85

    Joined:
    Jun 23, 2016
    Messages:
    4
    Operating System:
    Windows Vista Home Premium
  4. Tony D

    Tony D Administrator Administrator

    Joined:
    Sep 25, 2009
    Messages:
    4,562
    Location:
    SE Pennsylvania, USA
    Operating System:
    Windows XP Professional
    Thanks for the info. The link says no drivers are required and that it should work with Vista. Additionally, you said
    So Vista is recognizing the device.

    Maybe an issue with Proscan or a Vista setting.
     
  5. bdnh85

    bdnh85

    Joined:
    Jun 23, 2016
    Messages:
    4
    Operating System:
    Windows Vista Home Premium
    But when I plug it in or unplug its not in the device manager. If it's a Vista setting what do you suggest?
     
  6. Tony D

    Tony D Administrator Administrator

    Joined:
    Sep 25, 2009
    Messages:
    4,562
    Location:
    SE Pennsylvania, USA
    Operating System:
    Windows XP Professional
    It might be something with the Proscan software. I'm not familiar with that product.

    Maybe it doesn't recognize sound coming in from a USB-connected device. If you haven't already, try updating to the latest version of their software. I don't see a support forum on their site. There is a link for support: support@proscan.org.

    If it's a desktop PC, you can try installing another sound card instead of using the USB Sound adapter.

    Hopefully someone else here has another suggestion.
     
  7. bdnh85

    bdnh85

    Joined:
    Jun 23, 2016
    Messages:
    4
    Operating System:
    Windows Vista Home Premium
    Here what I got. When I went to Device manager nothing was listed. This is the 3rd USB sound card I went through as they bend easily.
    Does the Windows Device Manager show "Unknown"
    The OS reports the sound devices to ProScan so nothing can be done in ProScan. I would check first what the Windows Device Manager show and does it show as working
     

Share This Page